Getting Started
Official links and tools
PortalPortal  HomeHome  GlossaryGlossary  CalendarCalendar  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
WARLORDS OF DREANOR - RELEASE ON 13.11.2014

FOR THOSE HAVING CONNECTIVITY PROBLEMS CHECK HERE!

Share | 
 

 How to activate Chinese input under VISTA(Solved)

View previous topic View next topic Go down 
seanderham 
RaptorRaptor

Posts : 73
Joined : 2009-04-04

Character in WOW
Server: Flame Crest
Name: seandruid
Guild:

  Wed 24 Jun 2009 - 18:54  #
I know there have been various guides to help people write chinese in game but as far as Iv'e seen these have all been for windows XP. I have windows vista and I think thats why none of the solutions posted work for me. Im sure there are other with vista out there, have you found a way to fix the problem?


Last edited by seanderham on Thu 25 Jun 2009 - 12:52; edited 1 time in total
Khelben 
HarpyHarpy

Posts : 107
Joined : 2008-09-16

Character in WOW
Server:
Name: Overpowered
Guild: Foreign Shards

  Wed 24 Jun 2009 - 20:27  #
It should be the same, set your uni-code language to Chinese and turn on the Chinese IME or download one like the Google IME (which I use).
Lore 
RaptorRaptor

Posts : 62
Joined : 2008-04-27
Male Age : 44
Location : Dalian

Character in WOW
Server: 六区 - 永恒之井
Name: Lore
Guild: Heaven Corner

  Wed 24 Jun 2009 - 23:20  #
Not sure about vista, but on XP the setting referred to is under the 'Regional and Language options' in control panel.. 'Advanced' tab.. 'Language for non-Unicode programs'. Make sure that is set to Chinese (PRC).
Note: Changing this setting will require a reboot.

The standard Microsoft windows IME sucks - especially at high res. Google IME at least will be in English as opposed to Sogou (where all the options etc are in Chinese, but I prefer it as an IME)
bolomas 
AdminAdmin

Posts : 1726
Joined : 2009-05-12
Male Age : 34
Location : Shanghai

Character in WOW
Server: 奥特兰克-CN1(PVP) Horde
Name: Smallearth
Guild: The Crazy waiguorens

  Thu 25 Jun 2009 - 4:13  #
- go to Control Panel;
- click on Clock, Language and Region;
- click on Regional and Language Options;
- click on the Administrative tab;
- press the "Change System Locale ..." button;
- hit OK or enter Administrator credentials, when prompted;
- the drop-down list of available Locale options appears.
- choose the appropriate Locale eg Chinese (PRC), Chinese (Taiwan) etc.
- hit OK. The system will need to reboot, for the change to take effect.

Dont't forget to add a new keyboard language(eg. windows Chinese IME, google pinyin IME)
- hit the Keyboards and Languages tab, and then hit Change keyboards.
- Under Installed services, click Add.
- select the Specific Chinese language you want to add

I personnaly recommend you Google Pinyin. It's the program made by google, it's all in chinese install/options etc but his integration inside the programs is much better I find, and the best thing is you can setup a key other than SHIFT to swtich between chinese and english input, was quiet a problem for me before I used google pinyin caus many of my game keybindings require SHIFT as a modifier and sometimes weird things woud occur, like keys not responding, stuff like that.

BTW if you could change the Title of the topic as :
How to activate Chinese input under VISTA(Solved)
it might prove useful for other people in the futur. I remember I had big troubles to find how to activate it when I came from xp to vista

_________________
When you log on a realm type "/join english" to get in touch with the community members.
WoW English/Chinese glossary (2000+ translated words) found on wow-in-chinese.jfs-web.ch
English speakers are consolidating on the same realm for Cataclysm check this thread
Lore 
RaptorRaptor

Posts : 62
Joined : 2008-04-27
Male Age : 44
Location : Dalian

Character in WOW
Server: 六区 - 永恒之井
Name: Lore
Guild: Heaven Corner

  Thu 25 Jun 2009 - 9:45  #
Ah yes.. a little different in Vista I see Smile

As for the key bindings - yes, the common default language changing toggle is highly annoying - especially when you are used to a myriad of hotkeys for various applications. I ended up chooing a really awkward combination that barely any app will use or ALT+Shift+1 for English, ALT+Shift+2 for Chinese and removed all the other IME toggling hotkeys.

As a side note if some software or drivers are trying to install in Chinese, this is probably because you have the system locale or non-Unicode set to Chinese.

If you reset that to English before you install universal software or drivers, they should install in English. Afterwards you can change back to Chinese again. I have found that most drivers (nVidia, HP printers etc) all use this setting to determine what language they should use for setup. Perhaps this is Why Bolomas found GoogleIME to be Chinese. When I tried the Google IME it installed in English.
bolomas 
AdminAdmin

Posts : 1726
Joined : 2009-05-12
Male Age : 34
Location : Shanghai

Character in WOW
Server: 奥特兰克-CN1(PVP) Horde
Name: Smallearth
Guild: The Crazy waiguorens

  Thu 25 Jun 2009 - 10:37  #
A yeah Lore now you're saying that I just realize why you were saying that googleIME was in english when I couldn't find an english installer lol.
Sometimes it's good to disable the chinese local when installing some programs; for a short story :

Recently I switched back to windows xp french edition. When installing the OS I already installed the windows chinese IME and set the locale for chinese language. later I wanted to install the sp3 patch but each time it would fail at the same place, watched many thread on the web but none would offer a solution to my problem. Later I tried to install photoshop french edition and the install would also fail because instead of creating a folder with the french characters it would create a chinese symbol. So once I desactivated the chinese locale I could install photoshop AND my service pack 3 ^^
But so far I never had such kind of problem with an english os, just happens with languages using accent characters like french or spanish.

_________________
When you log on a realm type "/join english" to get in touch with the community members.
WoW English/Chinese glossary (2000+ translated words) found on wow-in-chinese.jfs-web.ch
English speakers are consolidating on the same realm for Cataclysm check this thread
Lore 
RaptorRaptor

Posts : 62
Joined : 2008-04-27
Male Age : 44
Location : Dalian

Character in WOW
Server: 六区 - 永恒之井
Name: Lore
Guild: Heaven Corner

  Fri 26 Jun 2009 - 1:00  #
Yeah.. it seems crazy that (on XP at least) most software installers look at the 'non-Unicode' setting to determine installation language - instead of looking at your 'location' or even the OS's own installation language.

Quite annoying to have all those extra reboots before and after software installations sometimes.
Sponsored content 


  Today at 12:54  #
 

How to activate Chinese input under VISTA(Solved)

View previous topic  View next topic  Back to top 
Page 1 of 1

Permissions in this forum: You cannot reply to topics in this forum
Foreign community at Chinese World of Warcraft  :: Technical support -
Forumotion's free forums | © phpBB | Free forum support | Report an abuse | Free forum