Getting Started
Official links and tools
PortalPortal  HomeHome  GlossaryGlossary  CalendarCalendar  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
WARLORDS OF DREANOR - RELEASE ON 13.11.2014

FOR THOSE HAVING CONNECTIVITY PROBLEMS CHECK HERE!

Share | 
 

 TW - 4.1 - Problem setting my locale! HELP!

View previous topic View next topic Go down 
galtster 
CorpseCorpse

Posts : 8
Joined : 2011-04-28

  Thu 28 Apr 2011 - 16:38  #
Hi,
After reinstalling the game about 100 times and getting very angry, I have found that there is a problem setting the locale for the game in the WTF/config file and also the data/enGB/realmlist file.
Here's what happens: I install the game and the first time I run the wow.exe I start in English checking all the EULA agreements etc and the English portal opens.
I go to the data/enGB/realmlist file and make the changes as below:

set realmlist tw.logon.worldofwarcraft.com
set patchlist enGB.patch.battle.net:1119/patch
set realmlistbn ""
set portal tw

However, when I start the game it changes to CHINESE!!!! I went to check the locale in the WTF/config file and it changed to "zhTW". I changed it back to "enGB" and started the game again but still it started in Chinese. After rechecking the WTF/config file, the locale had changed back to "zhTW"!!!!!!

After a few tests, it seems that if I change the settings in the data/enGB/realmlist file to:

set realmlist eu.logon.worldofwarcraft.com
set patchlist enGB.patch.battle.net:1119/patch
set realmlistbn ""
set portal eu

THEN IT STARTS IN ENGLISH! But this doesn't help me because my account is in on the Taiwan server and I can't log in. It seems the game checks what portal or realmlist is set in the data/enGB/realmlist file and changes the locale automatically.

Is anyone else having this problem? It's really irritating me and I don't know what else to do.
Thanks in advance.
bolomas 
AdminAdmin

Posts : 1726
Joined : 2009-05-12
Male Age : 33
Location : Shanghai

Character in WOW
Server: 奥特兰克-CN1(PVP) Horde
Name: Smallearth
Guild: The Crazy waiguorens

  Thu 28 Apr 2011 - 17:49  #
Something I don't understand is why in first place do you have the chinese local installed. but anyway. In the wow/data folder try to rename the folder zhTW into something else, or move it to another place in your disk.

Also you can try to make your config.wtf file read only.

Tell me if this worked.

_________________
When you log on a realm type "/join english" to get in touch with the community members.
WoW English/Chinese glossary (2000+ translated words) found on wow-in-chinese.jfs-web.ch
English speakers are consolidating on the same realm for Cataclysm check this thread
eden-san 
ImpImp

Posts : 11
Joined : 2011-04-28

  Thu 28 Apr 2011 - 18:40  #
I am having the same exact problem...
- Set the config file to read only (does not change anything)
- Deleted any zhTW folder (does not change anything, there is a process restoring them automatically everytime I start WoW)

Tried a few other things but no luck so far.

eden-san 
ImpImp

Posts : 11
Joined : 2011-04-28

  Thu 28 Apr 2011 - 18:45  #
For the people who might be stuck at a black screen when starting the game, it's because it's downloading /unpacking more data in chinese.

The game will start after some time (took me about 10-15minutes, can't remember exactly since I was watching a video during).
eden-san 
ImpImp

Posts : 11
Joined : 2011-04-28

  Thu 28 Apr 2011 - 18:49  #
Tried connecting on my VPN and starting the game, but no difference (I thought it might get the user's location from the IP/other, so I tried).

It seems to force the locale from the portal config.
eden-san 
ImpImp

Posts : 11
Joined : 2011-04-28

  Thu 28 Apr 2011 - 18:51  #
YES!!@!#!@#!!!
Setting the portal to us (eu for a european client) will fix the problem!

So here is my realmlist.wtf:

set realmlist tw.logon.worldofwarcraft.com
set patchlist enUS.patch.battle.net:1119/patch
set realmlistbn ""
set portal us

Cheers,
Eden.
skar 
MurlocMurloc

Posts : 37
Joined : 2010-12-04

  Thu 28 Apr 2011 - 20:04  #
for those who are stuck in chinese after eden-san tipp - try change locale parameter back to enUS in config.wtf in wtf folder.
galtster 
CorpseCorpse

Posts : 8
Joined : 2011-04-28

  Fri 29 Apr 2011 - 3:22  #
I did the same at Eden-San and changed the config.wtf folder to enUS and it worked.
Finally!
bolomas 
AdminAdmin

Posts : 1726
Joined : 2009-05-12
Male Age : 33
Location : Shanghai

Character in WOW
Server: 奥特兰克-CN1(PVP) Horde
Name: Smallearth
Guild: The Crazy waiguorens

  Fri 29 Apr 2011 - 4:06  #
Cheers guys, and thanks for sharing, I've changed the guides accordingly.

_________________
When you log on a realm type "/join english" to get in touch with the community members.
WoW English/Chinese glossary (2000+ translated words) found on wow-in-chinese.jfs-web.ch
English speakers are consolidating on the same realm for Cataclysm check this thread
chrizdxy 
CorpseCorpse

Posts : 5
Joined : 2011-04-28
Male Location : Shanghai

  Fri 29 Apr 2011 - 6:50  #
Thx guys Smile I've been having the same problems! Solved now!~
eden-san 
ImpImp

Posts : 11
Joined : 2011-04-28

  Fri 29 Apr 2011 - 17:48  #
Note that there seems to be a new setting to set the locale from the interface menu in-game... I feel stupid :-)
oromes 
ImpImp

Posts : 14
Joined : 2011-05-01

  Sun 1 May 2011 - 13:30  #
Hello guys,
I am a WoW player since vanila time (how i miss those days) and recently moved to China (mainland) because of work.

Thanks to the posts of the foreign community, i manage a account creation on TW site, and changed the loggin zone to that same account, althou i am still working on the chinese language.

Atm i cant still loggin, as says server down (yaeh i asked a chinese to translate.. lol).

Hope to see you guys real soon.
Cheers
Steven 
CritterCritter

Posts : 2
Joined : 2011-05-04

  Wed 4 May 2011 - 7:12  #
I am in Taiwan playing on US Servers. I use the US client of course so no problems whats so ever for me. However since I been here I have invited many chinese friends to play with me on US Servers. With the new patch 4.1 it seems I can not get their chinese clients to work on US server.

I would think doing everything opposite of this would work but it failed to work.

1) Update following line in World of Warcraft\WTF\Config.wtf
- SET locale "zhTW"

2) Update following line in World of Warcraft\Data\zhTW\realmlist.wtf
- set realmlist us.logon.worldofwarcraft.com
- set patchlist zhTW.patch.battle.net:1119/patch
- set realmlistbn ""
- set portal tw

Those where the changes I made I also tried many other variety but it just does not work.

The problem I am getting exactly is Client is all in Chinese when I launch via Launcher.exe. However it can not connect to US Servers.

When I launch with wow.exe it is all in english but can connect to US Servers.
Which is very weird as it doesnt even have the enUS locals in the files only zhTW local.

I tried to look everywhere but could not find any help, so was hoping someone here knew more information about it.
oromes 
ImpImp

Posts : 14
Joined : 2011-05-01

  Sat 7 May 2011 - 6:01  #
eden-san wrote:
Note that there seems to be a new setting to set the locale from the interface menu in-game... I feel stupid :-)

Where Exactly?? Can you post a screenshot pls?

ahhhh! nvm.. found it Smile
Sponsored content 


  Today at 21:38  #
 

TW - 4.1 - Problem setting my locale! HELP!

View previous topic  View next topic  Back to top 
Page 1 of 1

Permissions in this forum: You cannot reply to topics in this forum
Foreign community at Chinese World of Warcraft  :: Technical support -
Free forum | © phpBB | Free forum support | Report an abuse | Free forum