Getting Started
Official links and tools
PortalPortal  HomeHome  GlossaryGlossary  CalendarCalendar  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
WARLORDS OF DREANOR - RELEASE ON 13.11.2014

FOR THOSE HAVING CONNECTIVITY PROBLEMS CHECK HERE!

Share | 
 

 WOW CN in your language - PC - 5.3.0 - up to date

View previous topic View next topic Go down 
Go to page : Previous  1, 2
NaotaMyojin 
ImpImp

Posts : 17
Joined : 2011-03-06

  Mon 4 Feb 2013 - 12:28  #
I didn't stream much yet but as so far I could still make the step :

Quote :
Then open \wow\WTF\config.wtf :

Modify the line
Code:
SET portal "us"

as below,
Code:
SET portal "cn"

Then I was able to connect and see my characters, but I didn't even try to log in (i don't why i didn't try lol, was in a hurry). I guess it would work.

Then trying to manually update from the version I was, I also didn't tried yet. I'll after CNY !

Tell me if it worked for you Havoc
eddiek 
CritterCritter

Posts : 1
Joined : 2013-02-06

  Wed 6 Feb 2013 - 6:04  #
Hello All,

I used to play 2 years ago in France.
I would like to play again in China in french or english, but i'll like to know which foreign client I need.
Can I use the one I had when I bought CATA?
Will it upgrade to MOP after I change the settings as explain?
Or should I get a MOP client first?

Thanks
stItCh 
OnyxiaOnyxia

Posts : 865
Joined : 2006-12-16
Male Location : 99% Suzhou and 1% Germany

Character in WOW
Server: MaDuoLan - 马多兰, Menethil-米奈希爾-TW
Name: Juliask-Zobun
Guild: Cow Eaters

  Fri 8 Feb 2013 - 12:10  #
It will upgrade to MOP patch automaticly, just use your old client and let it patch to the latest version mentioned on the guide.
middy8989 
ImpImp

Posts : 14
Joined : 2013-03-29

  Fri 29 Mar 2013 - 17:15  #
Guys, i have this problem with fonts:
Using a russian client i can't see the chinese characters. Write in chinese i get by use "apploc". But the main problem is i cannot see the characters in the game(for example names), and the space between latters are big like this "b s f d" etc. What you can advice?

Ok, i decided the problems with space by install old fonts(60mb), but the problem with names still is problem. When i left click mouse and chouse "explore"(dont know in eng client how named) there i can see the chinese name in the window, but when in the avatar near by(not in explore window, still cant see)
Enea 
DragonmawDragonmaw

Posts : 123
Joined : 2011-05-17

Character in WOW
Server: 奥特兰克
Name: Enea
Guild: The Crazy Waiguoruns

  Fri 29 Mar 2013 - 18:46  #
You mean the names plates above the characters are just ?????

If so this, usually, is caused by addons. What addons are you using?


Can you see chinese in the Chat windows?
middy8989 
ImpImp

Posts : 14
Joined : 2013-03-29

  Fri 29 Mar 2013 - 18:52  #
Yes, i can see chinese in the chat, and i can write chinese. But The names where avatar near by is like "????". The client is clean, i didnt install any addon.

And also forget to add, i cant see the characters when i choise the server, all servers are like "????"


Last edited by middy8989 on Fri 29 Mar 2013 - 19:08; edited 1 time in total
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Fri 29 Mar 2013 - 20:52  #
You said in another thread that you used the old fonts. Use the new ones but give up typing in Russian?
The Russian thing is usually server side, since we often can't see what players type in Russian.
I'll try to update the fonts folder.
middy8989 
ImpImp

Posts : 14
Joined : 2013-03-29

  Sat 30 Mar 2013 - 4:36  #
No, use the new ones the space between letter like "п р и в е т". I think new fonts is only for english client, not russian...
Where did you guys find this fonts? in MPQ files? perhaps i can find it by myself in chinese client and copy to russian.
It look like a server problem, because when i explore other players(to see the items and etc on them) the name in the window become chinese characters, but it need like 1-2 sec to become from "????" => "characters"

Also please upload truly work new and old fonts again, maybe my fonts working incorrect.
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Sat 30 Mar 2013 - 5:13  #
The file factory fonts work. You unzip it and drag it to your WoW folder.

http://wow-in-chinese.forum2jeux.com/t2719-realm-names-are-question-marks#25262
middy8989 
ImpImp

Posts : 14
Joined : 2013-03-29

  Sat 30 Mar 2013 - 7:12  #
ok, im at office right now, if have a free time i'll try, then tell you work or not...
the url you give me is not for download fonts, but is for move to other thread, right?
If its possible can you upload the new and old fonts on chinese or some foreign site(but not on gamefront) i cant donwload from there no matter use the vpn or direct download.
middy8989 
ImpImp

Posts : 14
Joined : 2013-03-29

  Sat 30 Mar 2013 - 20:11  #
Ok, guys thanks for the moral support Smile
The problem is the Blizzard right after 5.0.2 patch add in the game new fonts:

FRIZQT___CYR
MORPHEUS_CYR
SKURRI_CYR

Dont know this fonts have all clients or only russian. But the problem is after copy the fonts (in the rar have 5 ttf files arialn, FRIENDS, frizqt__, morpheus, skurri), the game cant show a chinese characters because the names of the fonts has changes, it is above names with ___CYR.
SO FOR RUSSIAN CLIENT(AND FOR CLIENTS WHO HAVE THE SAME PROBLEMS):
1. You should download old fonts(for russian client) or new fonts for english. Russian client with new fonts working incorrect(big spaces between letters)
2. Second make 3 copy of any file in rar, and change the name
FRIZQT___CYR
MORPHEUS_CYR
SKURRI_CYR
3. Can play.

2Admin: please add it to the top post, because it was hard to find the decision of the problem and it will be very help for other people who have this problem
stItCh 
OnyxiaOnyxia

Posts : 865
Joined : 2006-12-16
Male Location : 99% Suzhou and 1% Germany

Character in WOW
Server: MaDuoLan - 马多兰, Menethil-米奈希爾-TW
Name: Juliask-Zobun
Guild: Cow Eaters

  Wed 3 Apr 2013 - 17:04  #
its as simple as it gets there is no specific font.....
just redo the guide we give u and u can play ....get the font files, install it and activate asien fonts have to be activated in windows ....THER U GO
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Wed 3 Apr 2013 - 19:28  #
stItCh wrote:
its as simple as it gets there is no specific font.....
just redo the guide we give u and u can play ....get the font files, install it and activate asien fonts have to be activated in windows ....THER U GO

Thanks Stitch cheers
StiXx 
NecromancerNecromancer

Posts : 702
Joined : 2008-06-11
Male Age : 30
Location : Guangzhou / Eindhoven

Character in WOW
Server: 奥特兰克-CN1(PVP)
Name: Avanti
Guild: The Crazy Waiguorens

  Wed 10 Apr 2013 - 7:42  #
Problem with EU client.

He guys

It seems the EU client isn't on the same patch as US / CN :S
Even after maintenance I can still logon to the EU server just fine but when I switch back to Chinese it still says there is a patch required.

-Tried changing the launcher.db back to enGB didn't work.
Suzhou-Alex 
SuccubusSuccubus

Posts : 204
Joined : 2008-06-22
Male Age : 45
Location : Suzhou

Character in WOW
Server: maduolan-马多兰
Name: Suzhoualex
Guild: Cow Eaters

  Wed 10 Apr 2013 - 8:10  #
Same here,

Yesterday evening it was fine. Since this morning it ask for an update.
middy8989 
ImpImp

Posts : 14
Joined : 2013-03-29

  Wed 10 Apr 2013 - 8:40  #
StiXx wrote:
Problem with EU client.

He guys

It seems the EU client isn't on the same patch as US / CN :S
Even after maintenance I can still logon to the EU server just fine but when I switch back to Chinese it still says there is a patch required.

-Tried changing the launcher.db back to enGB didn't work.

same with the russian client
StiXx 
NecromancerNecromancer

Posts : 702
Joined : 2008-06-11
Male Age : 30
Location : Guangzhou / Eindhoven

Character in WOW
Server: 奥特兰克-CN1(PVP)
Name: Avanti
Guild: The Crazy Waiguorens

  Wed 10 Apr 2013 - 11:27  #
I'm installing US client, if it happens today it will probably happen again.
sleepwholelife 
DefiasDefias

Posts : 54
Joined : 2011-01-19
Male Location : Beijing

Character in WOW
Server: 奥特兰克 (Alterac)
Name: Wakka
Guild: The Crazy Waiguorens

  Wed 10 Apr 2013 - 14:00  #
at first, update didn't do any result, now another problem. trying repair tool now.
...And repair tool fixed everything, nice.

middy8989 
ImpImp

Posts : 14
Joined : 2013-03-29

  Wed 10 Apr 2013 - 14:32  #
In launcher.db change ruRU, then start launcher, update the client. Then start wow.exe, and there is no problem =) Perhaps the chinese servers was update a little late then EU/US servers.
sleepwholelife 
DefiasDefias

Posts : 54
Joined : 2011-01-19
Male Location : Beijing

Character in WOW
Server: 奥特兰克 (Alterac)
Name: Wakka
Guild: The Crazy Waiguorens

  Wed 10 Apr 2013 - 14:33  #
yeah, but a while ago, in the early morning, this didnt work, now it's ok.
milescn 
CorpseCorpse

Posts : 6
Joined : 2012-06-18
Male

  Thu 16 May 2013 - 7:05  #
The point is,where do we DL the us client? Shocked
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Thu 16 May 2013 - 12:51  #
milescn wrote:
The point is,where do we DL the us client? Shocked

https://us.battle.net/account/download/?show=wow
hoisin 
DefiasDefias

Posts : 51
Joined : 2007-11-11
Male Age : 33

Character in WOW
Server: Area 4 - 澳得兰克
Name: wtfhoisinwtf
Guild: hoisin

  Fri 24 May 2013 - 2:20  #
wait...milescn? Is that the same miles that played from zhuhai and had the mage Atua?????????
Kadava 
MurlocMurloc

Posts : 43
Joined : 2010-02-05
Male Age : 35
Location : Changchun, Jilin Province

Character in WOW
Server: 主宰之剑
Name: 暗害
Guild: Shadow Ravenz

  Fri 24 May 2013 - 16:46  #

Mine is downloading the 327mb file of patch 5.3.0

is this right? I did everything as the thread said.
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Fri 24 May 2013 - 18:18  #
Kadava wrote:

Mine is downloading the 327mb file of patch 5.3.0

is this right? I did everything as the thread said.

Yes. Then apply the changes again.
Kadava 
MurlocMurloc

Posts : 43
Joined : 2010-02-05
Male Age : 35
Location : Changchun, Jilin Province

Character in WOW
Server: 主宰之剑
Name: 暗害
Guild: Shadow Ravenz

  Fri 24 May 2013 - 19:15  #

Yep, thanks mate, done it and its now working fine Smile
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Wed 12 Jun 2013 - 19:00  #
Just a note. A new (small) patch was released yesterday. Revert the changes made to your client and use the launcher to update. Then make the changes again.
Unkim 
DefiasDefias

Posts : 51
Joined : 2011-09-24
Male Location : Ningbo

Character in WOW
Server: Alterac Mountains
Name: Gnomespirit
Guild:

  Thu 27 Jun 2013 - 5:39  #
There is a new patch, and after update it, still asking to patch again... any ideas?
Crypton 
CorpseCorpse

Posts : 9
Joined : 2013-12-09

  Mon 9 Dec 2013 - 15:48  #
Hey guys, I am a Australian gamer who recently quit playing on us/oceanic realms due to high latency issues. I heard there are servers in tw / china and I'm interested in playing on them.

Only problem is I am having trouble setting it up so I can have the ui don't set to English, I am wondering if somebody would be nice enough to give me a hand setting it up on Skype, would be extremely appreciated since my latency is sooo much lower on these servers but I cannot understand the language of the game interface etc. if anybody is interested in helping me, my Skype is Bryce_stanton

It would truly mean the world to me if somebody could help <3
trueab1 
CorpseCorpse

Posts : 7
Joined : 2013-10-04
Male Age : 24
Location : Beijing

Character in WOW
Server:
Name:
Guild:

  Wed 23 Apr 2014 - 19:14  #
Hello people, thats Analfire.
I've got a problem. I installed battlenet app to play Heartstone, so now i cant update my wow client, cos it says that this game is for EU only.
My config.wtf is
me wrote:
SET locale "ruRU"
SET installLocale "enUS"
and
me wrote:
SET portal "cn"
keeps removing from there. What do i do?
Btw, how do u guys change launcher.db? What software u use?
Kadava 
MurlocMurloc

Posts : 43
Joined : 2010-02-05
Male Age : 35
Location : Changchun, Jilin Province

Character in WOW
Server: 主宰之剑
Name: 暗害
Guild: Shadow Ravenz

  Thu 24 Apr 2014 - 2:02  #
trueab1 wrote:
Hello people, thats Analfire.
I've got a problem. I installed battlenet app to play Heartstone, so now i cant update my wow client, cos it says that this game is for EU only.
My config.wtf is
me wrote:
SET locale "ruRU"
SET installLocale "enUS"
and
me wrote:
SET portal "cn"
keeps removing from there. What do i do?
Btw, how do u guys change launcher.db? What software u use?

Installing Hearthstone messed up my whole wow install, so I uninstalled and wont be installing HS again, bloody thing  Neutral 
Warmaster_Blackhorn 
Bloodscalp TrollBloodscalp Troll

Posts : 355
Joined : 2010-09-08
Male Location : Shanghai

Character in WOW
Server: Alterac澳得兰克 / Arygos亚雷戈斯
Name: Blackhorn, Scribbler, Whitehorn
Guild: Crazy Waiguorens

  Thu 24 Apr 2014 - 3:51  #
From what I and many others have seen so far, the battlenet client does screw things up. Basically, everytime you want to update wow, you have to reset (by deleting a cache directory somewhere) or reinstall the battlenet client.

I think the process which resolved it temporarily for me was this one: https://us.battle.net/support/en/article/deleting-battlenet-files

Blackhorn
trueab1 
CorpseCorpse

Posts : 7
Joined : 2013-10-04
Male Age : 24
Location : Beijing

Character in WOW
Server:
Name:
Guild:

  Thu 24 Apr 2014 - 13:27  #
Well, the problem is that i've tried deleting battlenet app and run launcher, which didnt help at all.
Thanks for information, will try to do so, will give results later
Reegard 
CritterCritter

Posts : 1
Joined : 2014-06-04

  Wed 4 Jun 2014 - 12:16  #
Если тут есть Русские, которые играют на Китайских серверах с русским клиентом - отпишитесь пожалуйста. Все авторы, которые ранее задавали вопросы - уже не активны. Очень нуждаюсь в Вашей помощи.
Enea 
DragonmawDragonmaw

Posts : 123
Joined : 2011-05-17

Character in WOW
Server: 奥特兰克
Name: Enea
Guild: The Crazy Waiguoruns

  Tue 24 Jun 2014 - 9:41  #
I have no issues updating my client using the method i posted in here..

http://wow-in-chinese.forum2jeux.com/t2895-update-client-with-new-battlenet-launcher-to-play-in-china

However some people have no problems with this, some it wont work... worth a try though
narnos 
CritterCritter

Posts : 1
Joined : 2014-09-08

  Thu 11 Sep 2014 - 15:22  #
uugh. ive tried this over and over step by step... every time i save the config.wtf file with a SET portal "cn" it disappears and I have had a failed attempt every time.

I had a brand new install to start with... and I think in the midst of trying to play in chinese I may have patched to chinese? Or maybe It worked and I didnt know everything would be in chinese? I thought you could play on china servers in english like the subject says.

any suggestions? why would my config.wtf never keep the SET portal "cn" after saving it?

can someone send me the US wow.exe wow-64.exe and wowlauncher.exe to start over? or should i reinstall the entire game?

I also tried the method above with the Launcher to play in china in it was another failed attempt.

HELP!
Warmaster_Blackhorn 
Bloodscalp TrollBloodscalp Troll

Posts : 355
Joined : 2010-09-08
Male Location : Shanghai

Character in WOW
Server: Alterac澳得兰克 / Arygos亚雷戈斯
Name: Blackhorn, Scribbler, Whitehorn
Guild: Crazy Waiguorens

  Fri 12 Sep 2014 - 0:18  #
Are you trying to run the game with wow-64.exe (or wow.exe) rather than the Battle.net launcher? Battle.net tries to "update" the game to the correct version, which can include rewriting the config.wtf, especially if you're changing log in from China to US or EU and back.

If you have the full English client, change the config.wtf, then launch with wow.exe and it should work.
Edgarzhuochen 
CorpseCorpse

Posts : 4
Joined : 2014-01-22

  Sat 18 Oct 2014 - 19:12  #
Warmaster_Blackhorn wrote:
Are you trying to run the game with wow-64.exe (or wow.exe) rather than the Battle.net launcher? Battle.net tries to "update" the game to the correct version, which can include rewriting the config.wtf, especially if you're changing log in from China to US or EU and back.

If you have the full English client, change the config.wtf, then launch with wow.exe and it should work.

Hi Blackhorn, been a while since we talked. I have a question here since it's a post dedicated to coordinate English interface and China server: if I have a Chinese client, is there any way I can change the language of interface from Chinese to English? Look forward to your reply, thx!
Rallist 
HarpyHarpy

Posts : 96
Joined : 2010-12-02
Male Location : Shanghai

Character in WOW
Server: Maduolan/Alterac
Name: Rallist/Mootisha
Guild: Cow Eaters/Crazy Waigourens

  Sun 19 Oct 2014 - 16:51  #
Hey Folks,

If I have the new battle.net thingy and I want to install a copy of WoW, do I do it under the Europe version part?
I'm a little confused now this thing has come up and don't really get how to drop a new copy of WoW that i can work with...

Thx
/Ralli

EDIT: Can't even get the party started...when i go install, it tells me i need to select at least one language (there are no choices and the pre-install section says default)...i can't even get on to install!! TT
sleepwholelife 
DefiasDefias

Posts : 54
Joined : 2011-01-19
Male Location : Beijing

Character in WOW
Server: 奥特兰克 (Alterac)
Name: Wakka
Guild: The Crazy Waiguorens

  Sun 19 Oct 2014 - 20:36  #
With a new battle.net launcher, you have to:

1. Install launcher
2. Change region to eu/us
3. Go offline mode
4. Download  patch
5. Change region to China and login.

Also need to change line in config. wtf (WTF folder) portal "us" or portal "eu"   to portal "cn" and vice versa when switch servers. Probably does not hurt to change line in launcher.db (Main folder) as well =  enUS enEU/zhCN.
ryuuken 
ImpImp

Posts : 11
Joined : 2011-06-24

  Mon 20 Oct 2014 - 21:26  #
Does anyone know how to do the opposite?
I'd like to run the Taiwanese version of WoW on the European servers.

I tried all kind of methods but when I try to login I get disconnected from server message..

Thanks
Rallist 
HarpyHarpy

Posts : 96
Joined : 2010-12-02
Male Location : Shanghai

Character in WOW
Server: Maduolan/Alterac
Name: Rallist/Mootisha
Guild: Cow Eaters/Crazy Waigourens

  Wed 29 Oct 2014 - 15:50  #
So, I'm doing a completely fresh install.

I have the fancy Battle.net launcher thing going and I'm trying to install a new copy of WoW from there. I've selected Europe as the region and (compared to my last post) I didn't need to select the language this time as it just started going.

The issue now is that it's been on the initial set up for EVER - "Fetching encoding table"

Any ideas on this or is 'saint-like' patience the key?

I've been waiting like an hour for them to go get this effing table.....

/Ralli
Chrisscho 
CritterCritter

Posts : 2
Joined : 2014-11-09

  Sun 9 Nov 2014 - 13:12  #
I could also use some support here.
I now changed everything written in the Text to the CN version, wow starts in english, i login with my new account and he says: Patch required.

Any new HowTO?

I would also like to be invited in the WeChat Group. chrisschobert is my id

Also If some1 would like to assist me setting up WoW I would appreciate that
Rallist 
HarpyHarpy

Posts : 96
Joined : 2010-12-02
Male Location : Shanghai

Character in WOW
Server: Maduolan/Alterac
Name: Rallist/Mootisha
Guild: Cow Eaters/Crazy Waigourens

  Wed 12 Nov 2014 - 17:15  #
Heya Again,

Has nobody else had any kind of issue with a fresh install this time around? I'm pretty much at a loss with what to do as i'm still going nowhere at the start of the install and it's telling me that it is "Fetching encoding table".
Any helpful advice would be massively appreciated.

/Ralli

EDIT: OK! Progress has been made...I've now got a copy of WoW on my system again and I followed Enea's advice about switching the location of Battle.net and I also changed the locations on the old files we've always switched over.

Issue now is...when I first started the game up, some lovely language options came up (I thought at the time, mistakenly, they may have been server options...stoopid i know). I naturally selected China and now my games entirely in Chinese.

Any advice at this stage for getting it back to English?

Here's what the top few lines of my WTF config file look like:-

SET portal "CN"
SET textLocale "zhCN"
SET audioLocale "enUS"
SET agentUID "wow_enus"

Any ideas plz people?

/Ralli
Sponsored content 


  Today at 11:33  #
 

WOW CN in your language - PC - 5.3.0 - up to date

View previous topic  View next topic  Back to top 
Page 2 of 2 Go to page : Previous  1, 2

Permissions in this forum: You cannot reply to topics in this forum
Foreign community at Chinese World of Warcraft  :: Technical support -
Free forum | © phpBB | Free forum support | Report an abuse | Free forum