Getting Started
Official links and tools
PortalPortal  HomeHome  GlossaryGlossary  CalendarCalendar  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
WARLORDS OF DREANOR - RELEASE ON 13.11.2014

FOR THOSE HAVING CONNECTIVITY PROBLEMS CHECK HERE!

Share | 
 

 WOW CN in your language - MAC - 5.1.0.16309 OUTDATED

View previous topic View next topic Go down 
Go to page : Previous  1, 2, 3  Next
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Tue 17 Apr 2012 - 12:37  #
Verilus wrote:
UHHHHHHHHH nvm uru ehehehheheeh apparently theres maintenance scheduled from 11:00pm today for 14hours

http://www.battlenet.com.cn/wow/zh/forum/topic/5191953249

decu
Sainte 
KoboldKobold

Posts : 25
Joined : 2012-02-01
Male Location : Shanghai

Character in WOW
Server:
Name:
Guild:

  Thu 19 Apr 2012 - 15:15  #
Can you post your patched version of World Of Warcraft Launcher.app and World of Warcraft.app?

Since the current steaming client always patches to 4.3.4, so it might get interfered with the Chinese patched 4.3.3 ones.

Edit: Confirmed. Couldn't work on my brand new 4.3.4 installation. Please upload your patched and original 4.3.3 "World Of Warcraft Launcher.app and World of Warcraft.app".
danziqi 
MurlocMurloc

Posts : 39
Joined : 2011-11-06
Male Location : Shangrao, Jiangxi

Character in WOW
Server: CN1 (奥特兰克)
Name:
Guild:

  Thu 19 Apr 2012 - 16:57  #
Look at post #2 in this thread. There you'll find the download link for the latest WoW and Launcher.app (Update from 14-04-2012).
Sainte 
KoboldKobold

Posts : 25
Joined : 2012-02-01
Male Location : Shanghai

Character in WOW
Server:
Name:
Guild:

  Thu 19 Apr 2012 - 22:10  #
Ok, after testing for a while I can now write these instructions.

Tested and working on current 4.3.4 streaming mac client. (2:00am 20/04/12)

Step 1:
Install your streaming client until the PLAY button is highlighted and the notice "World of Warcraft is up to date" appears. (Even though it isn't truly up to date)

Run "World of Warcraft.app" once, pass through those terms and conditions, confirm your client is functioning.

(Besides, you can either risk your life on making up from the Windows one, and assume "Data" of both enUS Windows and enGB Mac are identical.)


Step 2:
Since 4.3.4 is ready, you can start "patching" now.

I recommend you get the original "World of Warcraft.app" instead of this. (I have no idea whether this is patched or non-patched). But this is the only choice in the mean time.

Now, get the file from http://speedy.sh/7f2tP/download/WoW-CN-Mac-433-2736.zip

Extract it, delete the file "World of Warcraft Launcher.app" RIGHT AWAY. No, you don't need it or it would blow your whole computer up. Remember to empty trash just in case it could run back somehow.



Step 3:
Create a new folder inside Applications/World of Warcraft and name it "Backup".

Move the current 4.3.4 "World Of Warcraft Launcher.app" and "World of Warcraft.app" into that "Backup"

Right-click to Applications/World of Warcraft/Data/enGB (or your language version)/realmlist.wtf

Select "Duplicate" and rename the duplicated file to realmlist.wtf.bak. (self-explanatory)



Step 4:
Right-click to realmlist.wtf again, select Open With/Other/TextEdit.

Change the content into:

First line:
Code:
set realmlist cn.logon.warcraftchina.com

Fourth line:
Code:
set portal cn

Leave the second and third lines untouched.


Step 5:
Copy "World of Warcraft.app" you got from the archive into wow folder.

Make sure you have no any sort of launcher in your wow folder, or you will be screwed up.

Copy the "Fonts" from your Windows wow folder, and "AddOns" as well.

I also recommend using 64-bit client (functioning pretty well on 4G RAM Lion)
Direct link: http://us.media.battle.net.edgesuite.net/downloads/wow-installers/live/WoWLive-64-Mac-15354.zip
Just simply extract the content into your wow folder. No harm/virus/explosion detected.

Drag your desired wow.app to the Dock, to make shortcut.

Left-click to that W portrait.

Enter your Account name and password.

And now, you're in. But not yet.


Step 6:
You will notice at the game menu button (esc) that the client is still being downloaded. Don't panic, this is a very normal situation.

Now quit your dedicated playing.

Revert everything back to the original 4.3.4 version.

(Copy those wow and launcher back into wow folder, move that 4.3.3 wow to Backup, rename realmlist.wtf to .bbk. Rename realmlist.wtf.bak back to realmlist.wtf.)

Run "World Of Warcraft Launcher.app".

There will probably be about additional 6 GB to be downloaded. So have your patience.

When it's done, change your files back to the Chinese "patch".

Execute either wow.app or wow-64.app and now you're ready for raiding.




Conclusion:

If you're using 64-bit version, you will gain these benefits:
1. Compatible and beautiful graphics.
2. Stunning sound quality. (Recommend the Sony MDR-V300 headphone with headphone mode on)
2. Lightning speed loading bar. (Not including the first time playing)
3. Lag-free gaming experience. (Well, depends on when you play and where your char is, but really improved)


Apparently,
1. Risk-free updates in the future.
(Just have your former "World of Warcraft.app" backed up and you're free to update)

2. No bloody Chinese in-game patches/errors/failures required.


YY solution:
YY installation on iOS devices is the most convenient so far. Or Android devices also work perfectly.


Good luck.
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Fri 20 Apr 2012 - 12:47  #
Thanks Sainte. Updated as of 20/04/2012.
Sainte 
KoboldKobold

Posts : 25
Joined : 2012-02-01
Male Location : Shanghai

Character in WOW
Server:
Name:
Guild:

  Fri 20 Apr 2012 - 13:43  #
Well, you must not change the second line of realmlist.wtf or the wow.app can't be run.
Verilus 
FelhoundFelhound

Posts : 178
Joined : 2011-08-18
Male Age : 28
Location : Shanghai

Character in WOW
Server: CN1 奥特兰克 - PVP
Name: Gigatab/Tabasco
Guild: Crazy Waiguorens

  Fri 20 Apr 2012 - 17:04  #
after maintenance on monday i've been having buggy issues with bg. any one else have the same problem?
gaogao92 
ImpImp

Posts : 11
Joined : 2012-04-13
Male Age : 24
Location : Leeds, UK

  Sat 21 Apr 2012 - 6:37  #
Hi my world of warcraft app can't be run with a error said Cannot steam required archive date.Please check network connection . I follow the every steps on first page.
Verilus 
FelhoundFelhound

Posts : 178
Joined : 2011-08-18
Male Age : 28
Location : Shanghai

Character in WOW
Server: CN1 奥特兰克 - PVP
Name: Gigatab/Tabasco
Guild: Crazy Waiguorens

  Tue 24 Apr 2012 - 10:24  #
so with us servers mac we need to revert back to us realmlist file or just start up directly and let it patch?
Verilus 
FelhoundFelhound

Posts : 178
Joined : 2011-08-18
Male Age : 28
Location : Shanghai

Character in WOW
Server: CN1 奥特兰克 - PVP
Name: Gigatab/Tabasco
Guild: Crazy Waiguorens

  Tue 24 Apr 2012 - 12:05  #
MAC PATCHING FROM 4.3.3 TO 4.3.4

1. Revert realmlist back to US

2. Use Repair tool

3. Update to 4.3.4 using launcher.app

4. Change realmlist back to CN

5. Use wow.app and wait until you see repair button

6. Press the damn button

7. You are now updated and can enjoy using wow.app Smile
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Tue 24 Apr 2012 - 15:45  #
Updated as of 24/04/2012 (DD/MM/YYYY).

Remember to update to 4.3.4 with Verilus' method!
Felidae 
CorpseCorpse

Posts : 4
Joined : 2012-04-26

  Fri 27 Apr 2012 - 7:56  #
Hey folks, haven't played in a while so I thought I might see what the Chinese servers are like. I'm based in Shanghai. I've followed the guide in the first post, starting from a blank slate, but when I try and log in, it says "Patch required.". If I click "Restart" it downloads the patch then says "No patch file found".

Thoughts?
Verilus 
FelhoundFelhound

Posts : 178
Joined : 2011-08-18
Male Age : 28
Location : Shanghai

Character in WOW
Server: CN1 奥特兰克 - PVP
Name: Gigatab/Tabasco
Guild: Crazy Waiguorens

  Fri 27 Apr 2012 - 9:53  #
you need to patch using US realmlist all the way first, then use the CN realmlist to patch the chinese tool and log in using wow.app not launcher.

if you've done that then try repairing with US realmlist then going back to CN realmlist again.

basically, always use US realmlist for major patches and log into game using CN realmlist Smile
Felidae 
CorpseCorpse

Posts : 4
Joined : 2012-04-26

  Fri 27 Apr 2012 - 10:34  #
That's exactly what I did. I completely removed WoW from my computer this morning. Then I downloaded the installer from Battle.net, let it patch itself up to 4.3.4 then waiting for it to download all 10GBs or so of data. Then I put the font files in the folder. Then I switched the realmlist to China, tried to log in, and it said I need to patch my client, which proceeded to fail.

Now when I try to repair with the US realmlist, it says it can't connect to Blizzard's servers.

I also just tried open wow.app again (I never use the launcher) with the Chinese realmlist and it says it can't validate my username/password.

Should I be using a Chinese account for this? Can I not use my North American Battle.net WoW account that I pay monthly for?

Thanks guys.
Verilus 
FelhoundFelhound

Posts : 178
Joined : 2011-08-18
Male Age : 28
Location : Shanghai

Character in WOW
Server: CN1 奥特兰克 - PVP
Name: Gigatab/Tabasco
Guild: Crazy Waiguorens

  Fri 27 Apr 2012 - 10:41  #
thats the problem.

yes. you need a chinese account. you cant use your north american bnet on a chinese server
Verilus 
FelhoundFelhound

Posts : 178
Joined : 2011-08-18
Male Age : 28
Location : Shanghai

Character in WOW
Server: CN1 奥特兰克 - PVP
Name: Gigatab/Tabasco
Guild: Crazy Waiguorens

  Fri 27 Apr 2012 - 10:43  #
if you want to use your NA account then you'll just be using the regular us client on mac and you'll need a vpn for your latency. otherwise you're welcome to join our chinese servers as leveling is really fast Smile
Felidae 
CorpseCorpse

Posts : 4
Joined : 2012-04-26

  Fri 27 Apr 2012 - 10:48  #
Well then. Hopefully when I set that up there's no more problems. Thanks!
aegides 
CorpseCorpse

Posts : 5
Joined : 2012-06-06

  Thu 7 Jun 2012 - 10:09  #
awesome guide, installed english version on my mac and working Very Happy

one problem though, my wow is 4.3.4 (15595) and while i am playing there is ingame download still going on and stuck at 68% not moving anywhere. I tried to finish it by using Launcher but it keeps on saying check ur connection (i also changed the pathcing back to us realmlist.wtf, still no go)

what am i doing wrong here? my latency is 100-200 from beijing to TCW server i think its because of the ingame download. on my bootcamped windows its 20-30ms.
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Thu 7 Jun 2012 - 11:12  #
Hey,

Ingame download does work actually. It's just terribly slow. As for the Launcher, I'm not a 100% sure since I didn't have this problem when updating.

Have you completely changed the realmlist.wtf back to:

Code:
set realmlist us.logon.worldofwarcraft.com
set patchlist us.version.worldofwarcraft.com
set realmlistbn ""
set portal us

Also, I had issues with the mac firewall when trying to update. Try using the launcher without. I'll look into this.
hubu1122 
ImpImp

Posts : 18
Joined : 2008-12-17
Male Location : Beijing

Character in WOW
Server:
Name: Schlumpf
Guild: TheCrazyWaiguorens

  Wed 13 Jun 2012 - 14:48  #
Hey Guys,

I downloaded the client for my mac and it installed the game, but as soon as the launcher opened and actually started to patch an error message appeared stating something like; internal error. please contact blizzard technical support.
I tried deleting it and downloading a different client (language wise), but nothing seems to work,
Looking at the guide the part after the patching is done seems rather simple.. but i just cant get further than this..
Any ideas? anyone with similar issues?

Thanks in Advance,
Alex
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Wed 13 Jun 2012 - 19:03  #
Hey Alex,

Delete the following folders:

- Interface, WTF, and cache folder located in Applications/World of Warcraft

Then, run the repair.app found in Applications/World of Warcraft.

By any chance, are you using a 64-bit client on your Mac? If so, read http://us.battle.net/wow/en/forum/topic/4079625992 .

Cheers,

Uru.
hubu1122 
ImpImp

Posts : 18
Joined : 2008-12-17
Male Location : Beijing

Character in WOW
Server:
Name: Schlumpf
Guild: TheCrazyWaiguorens

  Thu 14 Jun 2012 - 6:51  #
Thanks for the fast reply uru (:

I am pretty sure I didn't download the 64bit version as I used the download link, which is posted at the beginning of this thread..
Just deleted those files and repaired it. Repair told me to download a new client..so that's what I am doing now and then i'll try again!

Cheers, Alex
hubu1122 
ImpImp

Posts : 18
Joined : 2008-12-17
Male Location : Beijing

Character in WOW
Server:
Name: Schlumpf
Guild: TheCrazyWaiguorens

  Thu 14 Jun 2012 - 7:14  #
Same thing after deleting Interface, WTF and Cache and running repair the following pops up: Repair is unable to find necessary data on our servers. Please reinstall the game to play World of Warcraft.

It showed before the error message
Detected Expansion: Burning Crusade
Detected Locales: deDe
Detected Version: 12911
Just double checked, now I am a hundred percent sure it's not the 64bit version...

Any ideas?
Cheers
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Thu 14 Jun 2012 - 9:06  #
Hey Alex,

What kind of Mac do you have? If it's wireless, try bypassing the modem.
Blizzard Employee wrote:

This mainly happens due to connectivity issues. Is the iMac wireless? I would try bypassing any routers and directly connect to the modem.

Bypassing the router
1. Unplug the power to your modem.
2. Follow the ethernet cable from the modem to the router. Unplug it from the router.
3. Plug this end into your computer.
4. Plug the power back into your modem and let it start up.
5. Restart your computer.
6. Test.


If you have your firewall enabled, try disabling it before patching.

If none of the above work, you'll have to go with the long way: http://us.battle.net/wow/en/forum/topic/1406724418#3
hubu1122 
ImpImp

Posts : 18
Joined : 2008-12-17
Male Location : Beijing

Character in WOW
Server:
Name: Schlumpf
Guild: TheCrazyWaiguorens

  Fri 15 Jun 2012 - 8:52  #
Thanks Uru!

It actually worked, i used my ethernet and the patching went on till version 4.3.4 (15595)

But now i've got the next issue.. I changed the realmlist and made a bakup as it says (i didnt extract the fonds because both of the downloads wouldn't open, so i couldnt extract them..not sure if they are meant for mac?) then i started wow with the app and it opened. when i logged inn it said something a new update has to be downloaded so it ended WoW downloaded some kind of patch (16mb or so) and when i tried to log inn after i couldnt. It would tell me that my password is wrong and something about wow europe. So i think i did something wrong with the realmlist or something?

Any clue what this patch was about and why i cant log inn? also i cant open my launcher anymore. says i should check my internet connection and try again.

Thanks for your great help. alex
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Fri 15 Jun 2012 - 11:05  #
Hey Alex,

To open .zip's on mac, you need the the Unarchiver app for mac.

Was the name of the downloaded patch in chinese? What is your game's version now (check the numbers after 4.3.4)?

EDIT: Just checked Blizzard's official site and from what I gather, you either downloaded a chinese patch (doesn't do anything) or messed up while changing the realmlist and downloaded a patch meant for the US/EU that fixes bugs.
The message about not being able to connect to European servers = wrong realmlist? You need to name one of the realmlists, "realmlist.wtf.bak".
Otherwise, can you go to WoW/WTF/Config.wtf and paste the contents here?
hubu1122 
ImpImp

Posts : 18
Joined : 2008-12-17
Male Location : Beijing

Character in WOW
Server:
Name: Schlumpf
Guild: TheCrazyWaiguorens

  Fri 15 Jun 2012 - 13:36  #
okayy soo the version is 4.3.4 15595 (release x86) whatever that means haha..

realmlist is correct and ive the back up one too..

config.wtf:

SET readTOS "1"
SET readEULA "1"
SET readScanning "1"
SET readContest "-1"
SET locale "deDE"
SET showToolsUI "1"
SET accounttype "CL"
SET readTerminationWithoutNotice "1"
SET installType "Retail"
SET portal "cn"
SET hwDetect "0"
SET gxRefresh "60/1"
SET videoOptionsVersion "4"
SET Sound_MusicVolume "0.40000000596046"
SET Sound_AmbienceVolume "0.60000002384186"
SET farclip "185"
SET particleDensity "10"
SET baseMip "1"
SET environmentDetail "50"
SET textureFilteringMode "0"
SET weatherDensity "0"
SET playIntroMovie "4"

mhmm...thanks for your efforts! (:
hubu1122 
ImpImp

Posts : 18
Joined : 2008-12-17
Male Location : Beijing

Character in WOW
Server:
Name: Schlumpf
Guild: TheCrazyWaiguorens

  Fri 15 Jun 2012 - 14:04  #
okay so im pretty sure its a chinese patch, cause it had the heading zh something and after there was a mini patch showing chinese characters, so yea.. what i noticed though was that after that patch WoW automatically wants to open my launcher, but each time it tries it says no patch information can be found, please check ur internet connection.
Dont know if that does anything to the situation, but the more detail the better i guess ;P
btw haha i got the fonts now..thanks for the link!
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Fri 15 Jun 2012 - 14:14  #
If you name your launcher into "Launcher.app.bak" and start "WoW.app" does it work?
hubu1122 
ImpImp

Posts : 18
Joined : 2008-12-17
Male Location : Beijing

Character in WOW
Server:
Name: Schlumpf
Guild: TheCrazyWaiguorens

  Sat 16 Jun 2012 - 7:30  #
doesn't work either. mhmm
Xiansheng2 
CritterCritter

Posts : 1
Joined : 2012-06-30

  Sat 30 Jun 2012 - 1:39  #
Hi, I'm new here..

So is there a new AND simple way of doing this for the latest patch using a foreign client for Mac? If so could someone tell me how? I would greatly appreciate this.
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Sat 30 Jun 2012 - 6:28  #
Xiansheng2 wrote:
Hi, I'm new here..

So is there a new AND simple way of doing this for the latest patch using a foreign client for Mac? If so could someone tell me how? I would greatly appreciate this.

Follow the guide on page 1 of this thread.

Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Wed 29 Aug 2012 - 12:44  #
So patch 5.0.4 hit the EU/US realms yesterday and I can't login as my WoW.app does not respond. Is anyone else having this problem?
danziqi 
MurlocMurloc

Posts : 39
Joined : 2011-11-06
Male Location : Shangrao, Jiangxi

Character in WOW
Server: CN1 (奥特兰克)
Name:
Guild:

  Wed 29 Aug 2012 - 15:03  #
My WoW is still on 4.3.4 and I can play on chinese servers. It is important that the realmlist is set to chinese server, also the update server as follows:

set realmlist cn.logon.warcraftchina.com
set patchlist zhCN.patch.battle.net:1119/patch
set realmlistbn ""
set portal cn
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Wed 29 Aug 2012 - 15:05  #
danziqi wrote:
My WoW is still on 4.3.4 and I can play on chinese servers. It is important that the realmlist is set to chinese server, also the update server as follows:

set realmlist cn.logon.warcraftchina.com
set patchlist zhCN.patch.battle.net:1119/patch
set realmlistbn ""
set portal cn

Hmmm... I'm beginning to suspect that it might be due to Sainte's guide that I might have followed in the past. Would you mind uploading your WoW.app, WoWLauncher.app, Repair.app, Backgrounddownloader.app and Blizzard updater.app please?

EDIT: I just checked my Time Machine'd copy of WoW dating from the 20th August, and the second line of realmlist.wtf was set on enGB. I could still log in though.
bolomas 
AdminAdmin

Posts : 1726
Joined : 2009-05-12
Male Age : 33
Location : Shanghai

Character in WOW
Server: 奥特兰克-CN1(PVP) Horde
Name: Smallearth
Guild: The Crazy waiguorens

  Wed 29 Aug 2012 - 15:54  #
If the app files doesn' work, maybe try also to use dianziqi's WoW.mfil and Wow.tfil

Having the chinese patch server in the realmlist.wtf is important, not the first time ppl got owned this way.

_________________
When you log on a realm type "/join english" to get in touch with the community members.
WoW English/Chinese glossary (2000+ translated words) found on wow-in-chinese.jfs-web.ch
English speakers are consolidating on the same realm for Cataclysm check this thread
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Wed 29 Aug 2012 - 16:00  #
Can't download Danziqi's files. Speedyshare can't find them Sad
danziqi 
MurlocMurloc

Posts : 39
Joined : 2011-11-06
Male Location : Shangrao, Jiangxi

Character in WOW
Server: CN1 (奥特兰克)
Name:
Guild:

  Wed 29 Aug 2012 - 16:05  #
Yes I'm already working on it. Give me a few minutes...
danziqi 
MurlocMurloc

Posts : 39
Joined : 2011-11-06
Male Location : Shangrao, Jiangxi

Character in WOW
Server: CN1 (奥特兰克)
Name:
Guild:

  Wed 29 Aug 2012 - 16:13  #
OK...I've updated the download in the 2nd post. All the 4.3.4 app-files and the WoW.mfil / Wow.tfil are included. Hope it will help.
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Wed 29 Aug 2012 - 17:05  #
Hmph. Still getting the famous "Cannot stream archive data error".

Thanks for the files!

EDIT: After a bit of messing around, I managed to launch the game by changing "set locale enGB" to "set locale zhCN" in Config.wtf . It works, although all of the data I streamed previously is gone, meaning long load screens, etc. Otherwise, if the locale is set back to enGB I can't launch the game and still get the "Cannot Archive game data..." error (firewall is disabled and it still doesn't work).

EDIT 2: I got my backup client, (the one that was working previously before 5.0.4), changed the realmlist and it worked -.-. Thanks for the help!
danziqi 
MurlocMurloc

Posts : 39
Joined : 2011-11-06
Male Location : Shangrao, Jiangxi

Character in WOW
Server: CN1 (奥特兰克)
Name:
Guild:

  Wed 5 Sep 2012 - 15:22  #
Oh I love these updates! First it took 7 hours to download the 6GB of the 5.0.4 patch and now the launcher is streaming the next 6,5GB! Hey Blizzard most of us have only slow Internet connections here in China! Argh... As soon as the patching is done, I will update the files in post #2... hmmm

Edit: Post #2 is now up to date for version 5.0.4
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Thu 6 Sep 2012 - 19:29  #
Thanks, Danziqi.
danziqi 
MurlocMurloc

Posts : 39
Joined : 2011-11-06
Male Location : Shangrao, Jiangxi

Character in WOW
Server: CN1 (奥特兰克)
Name:
Guild:

  Tue 18 Sep 2012 - 15:36  #
OK WoW-Junkies out there - the next patch is online.
If you have any trouble during login to the server and usually start the game with WoW.app you might still be on 5.0.4! End the game and start the launcher.app, the patch will be downloaded and installed then (only about 28 MB). Now you should be on 5.0.5 and able to login.

For all of you, need the latest WoW app-files (after moving from Windows or backup), the links in post #2 have been updated to 5.0.5 as well! chinese
StiXx 
NecromancerNecromancer

Posts : 702
Joined : 2008-06-11
Male Age : 30
Location : Guangzhou / Eindhoven

Character in WOW
Server: 奥特兰克-CN1(PVP)
Name: Avanti
Guild: The Crazy Waiguorens

  Wed 5 Dec 2012 - 5:35  #
Hey Guys,

I cant find my repair tool :S

Keep getting this:

An internal error occured please restart launcher or contact customer support.

What to do?
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Wed 5 Dec 2012 - 15:42  #
I've deleted the outdated first post. Danziqi, this thread is now yours!
StiXx 
NecromancerNecromancer

Posts : 702
Joined : 2008-06-11
Male Age : 30
Location : Guangzhou / Eindhoven

Character in WOW
Server: 奥特兰克-CN1(PVP)
Name: Avanti
Guild: The Crazy Waiguorens

  Thu 6 Dec 2012 - 10:49  #
I reinstalled so for me its fixed.
But would like to know for future reference what guide do I need to use to update?

Simply changing the config file and launcher back didnt do it for me.
danziqi 
MurlocMurloc

Posts : 39
Joined : 2011-11-06
Male Location : Shangrao, Jiangxi

Character in WOW
Server: CN1 (奥特兰克)
Name:
Guild:

  Sun 30 Dec 2012 - 13:24  #
StiXx wrote:
I reinstalled so for me its fixed.
But would like to know for future reference what guide do I need to use to update?

Simply changing the config file and launcher back didnt do it for me.

Right, the update to 5.1.0 was a bit tricky this time. I couldn't update my Macversion as well and had to do it via Bootcamp with the Windowsversion. Let's hope the following minor updates will work with Launcher again...
danziqi 
MurlocMurloc

Posts : 39
Joined : 2011-11-06
Male Location : Shangrao, Jiangxi

Character in WOW
Server: CN1 (奥特兰克)
Name:
Guild:

  Sun 30 Dec 2012 - 13:30  #
Urubaen wrote:
I've deleted the outdated first post. Danziqi, this thread is now yours!

I've updated the files in post #1 to the latest version and will keep it up date.
Does somebody know, how to change the thread name, didn't find that option? scratch
Urubaen 
AdminAdmin

Posts : 1480
Joined : 2009-02-26
Male Location : London

Character in WOW
Server: 奥特兰克 - CN1(PVP)
Name: Sandre
Guild: TCW

  Sun 30 Dec 2012 - 15:44  #
There should be an edit post button near the button.

Anyways, I've changed it for you.

EDIT: I've just noticed that your guide mostly deals with players that already have the Windows client and want to play on Mac OS X by modifying certain files. Should I add a guide for players that start directly from the Mac client?
danziqi 
MurlocMurloc

Posts : 39
Joined : 2011-11-06
Male Location : Shangrao, Jiangxi

Character in WOW
Server: CN1 (奥特兰克)
Name:
Guild:

  Sun 30 Dec 2012 - 16:03  #
Think this could be helpful. Is it possible that u just write above my first post? Then we don't need 2 Mac threads... Or we open a new thread and close the old one. What do u think?
Sponsored content 


  Today at 18:38  #
 

WOW CN in your language - MAC - 5.1.0.16309 OUTDATED

View previous topic  View next topic  Back to top 
Page 2 of 3 Go to page : Previous  1, 2, 3  Next

Permissions in this forum: You cannot reply to topics in this forum
Foreign community at Chinese World of Warcraft  :: Technical support -
Free forum hosting  | © phpBB | Free forum support | Report an abuse | Free forum