Getting Started
Official links and tools
PortalPortal  HomeHome  GlossaryGlossary  CalendarCalendar  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
WARLORDS OF DREANOR - RELEASE ON 13.11.2014

FOR THOSE HAVING CONNECTIVITY PROBLEMS CHECK HERE!

Share | 
 

 Patch required issue

View previous topic View next topic Go down 
partyboyz 
Edwin Van CleefEdwin Van Cleef

Posts : 61
Joined : 2007-05-10

  Thu 11 Oct 2012 - 1:04  #
Tried logging in today and constantly getting a new patch required error during login. Anyone else getting this problem?
Klintonix 
DragonmawDragonmaw

Posts : 133
Joined : 2011-08-28
Male Age : 28

Character in WOW
Server: CN1 奥特兰克 (Alterac) CN5 亚雷戈斯 (Arygos)
Name: Klintonix / Klintonixia
Guild: The Crazy Waiguorens TCW

  Thu 11 Oct 2012 - 1:33  #
Same issue here.

I checked on the Chinese client and it downloaded a small patch (5MB).
Patch version: 5.0.5 (16135) Oct 8 2012.

It looks like 5.0.5b hit CN realms just like it did on EU/US yesterday.
Klintonix 
DragonmawDragonmaw

Posts : 133
Joined : 2011-08-28
Male Age : 28

Character in WOW
Server: CN1 奥特兰克 (Alterac) CN5 亚雷戈斯 (Arygos)
Name: Klintonix / Klintonixia
Guild: The Crazy Waiguorens TCW

  Thu 11 Oct 2012 - 2:00  #
I found a solution. After patching the Chinese client I copied WoW Launcher.exe and WoW.exe files from CN client and pasted them in the EU client replacing the 2 files.

Works for me, I can log in.

I'm putting those files on SkyDrive to download http://sdrv.ms/OUwObH.

If you're unable to download tell me, I'll upload somewhere else.
kappak 
MurlocMurloc

Posts : 36
Joined : 2011-12-11
Male

  Thu 11 Oct 2012 - 4:08  #
This worked for me:
1) Edit Launcher.db: change zhCN to enUS
2) Run wow launcher and let it update, close when it says done
3) Change Launcher.db from enUS back to zhCN
4) Run wow.exe (not launcher)
hoisin 
DefiasDefias

Posts : 51
Joined : 2007-11-11
Male Age : 33

Character in WOW
Server: Area 4 - 澳得兰克
Name: wtfhoisinwtf
Guild: hoisin

  Thu 11 Oct 2012 - 4:23  #
kappak wrote:
This worked for me:
1) Edit Launcher.db: change zhCN to enUS
2) Run wow launcher and let it update, close when it says done
3) Change Launcher.db from enUS back to zhCN
4) Run wow.exe (not launcher)

Hey kappak do I need to change the WTF folder config files or what not? Or just edit launcher.db? since I am scared to messup my game again and then redownload it haha! Thanks

HoiSin the bad pally!
kappak 
MurlocMurloc

Posts : 36
Joined : 2011-12-11
Male

  Thu 11 Oct 2012 - 5:11  #
Just edit the launcher.db in the main folder with notepad. I changed nothing else.
Eidjr 
CorpseCorpse

Posts : 6
Joined : 2012-09-25
Male Location : Beijing

Character in WOW
Server: 奥特兰克
Name: 丿凋零丶夜寐
Guild: The Crazy Waiguorens

  Thu 11 Oct 2012 - 5:32  #
I tried to download the new patch (changed Configuration to US and tried) it worked and The us was all good, but then I changed the enUS back to zhCN and wow turned chinese! i was able to log in but everything was in chinese!
I use a mac, anyone knows a fix? and If I make the config file back to enUS it goes back to english
Eidjr 
CorpseCorpse

Posts : 6
Joined : 2012-09-25
Male Location : Beijing

Character in WOW
Server: 奥特兰克
Name: 丿凋零丶夜寐
Guild: The Crazy Waiguorens

  Thu 11 Oct 2012 - 5:41  #
Ehh nvm I fixed it, just had to add the SET portal "cn" line into the configurations
stItCh 
OnyxiaOnyxia

Posts : 865
Joined : 2006-12-16
Male Location : 99% Suzhou and 1% Germany

Character in WOW
Server: MaDuoLan - 马多兰, Menethil-米奈希爾-TW
Name: Juliask-Zobun
Guild: Cow Eaters

  Thu 11 Oct 2012 - 14:48  #
confirmed kappak solution
Gruumsh44 
WyrmWyrm

Posts : 566
Joined : 2007-06-27
Male Age : 33

Character in WOW
Server: region 4 澳得兰克
Name: Gruumsh
Guild: Crazy WaiGuoRens

  Thu 11 Oct 2012 - 15:37  #
my Launcher.db was already enUS, DLed, then changed to zhCN worked... but 800+ ppl in queue before me... so not checking in now.
Kadava 
MurlocMurloc

Posts : 43
Joined : 2010-02-05
Male Age : 35
Location : Changchun, Jilin Province

Character in WOW
Server: 主宰之剑
Name: 暗害
Guild: Shadow Ravenz

  Fri 12 Oct 2012 - 6:52  #
Simply worked for me like this:

In the config.wtf Rename this line: SET portal "cn" to SET portal "us"

And then change the realmlist.wtf to this:

set realmlist us.logon.worldofwarcraft.com
set patchlist enUS.patch.battle.net:1119/patch
set realmlistbn ""
set portal us


Use the launcher as normal, update! once its done revert back
to everything you changed like this:

Config.wtf:

SET portal "cn"

Realmlist.wtf:

set realmlist cn.logon.warcraftchina.com
set patchlist zhCN.patch.battle.net:1119/patch
set realmlistbn ""
set portal cn


Run the game and your good to go Smile
Gruumsh44 
WyrmWyrm

Posts : 566
Joined : 2007-06-27
Male Age : 33

Character in WOW
Server: region 4 澳得兰克
Name: Gruumsh
Guild: Crazy WaiGuoRens

  Wed 12 Dec 2012 - 6:54  #
For this patch... i left my launcher DB at enUS, realmlist and config no change. used launcher to update, changed it to launcher.bak after patch and used the wow.exe, changed nothing else.
Mister_Evening 
DefiasDefias

Posts : 52
Joined : 2012-11-03

Character in WOW
Server: Alterac
Name: Kuroko/Fierylove/Not Frozenlove
Guild: The Crazy Waiguoren

  Wed 12 Dec 2012 - 13:10  #
Kadava wrote:
Simply worked for me like this:

In the config.wtf Rename this line: SET portal "cn" to SET portal "us"

And then change the realmlist.wtf to this:

set realmlist us.logon.worldofwarcraft.com
set patchlist enUS.patch.battle.net:1119/patch
set realmlistbn ""
set portal us


Use the launcher as normal, update! once its done revert back
to everything you changed like this:

Config.wtf:

SET portal "cn"

Realmlist.wtf:

set realmlist cn.logon.warcraftchina.com
set patchlist zhCN.patch.battle.net:1119/patch
set realmlistbn ""
set portal cn


Run the game and your good to go Smile

I also did it like this, for some reason my friend doesnt have said problems and he just changes launcher.db like Kappak to get his to work :/
Sponsored content 


  Today at 7:30  #
 

Patch required issue

View previous topic  View next topic  Back to top 
Page 1 of 1

Permissions in this forum: You cannot reply to topics in this forum
Foreign community at Chinese World of Warcraft  :: Technical support -
Free forum | © phpBB | Free forum support | Report an abuse | Forumotion.com