Getting Started
Official links and tools
PortalPortal  HomeHome  GlossaryGlossary  CalendarCalendar  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
WARLORDS OF DREANOR - RELEASE ON 13.11.2014

FOR THOSE HAVING CONNECTIVITY PROBLEMS CHECK HERE!

Share | 
 

 Update client with new Battle.net Launcher to play in China

View previous topic View next topic Go down 
Enea 
DragonmawDragonmaw

Posts : 123
Joined : 2011-05-17

Character in WOW
Server: 奥特兰克
Name: Enea
Guild: The Crazy Waiguoruns

  Thu 22 May 2014 - 11:08  #
This may help someone.. this is how i update with the new Launcher.  Works for me...

Load the new launcher.

Drop down the location box and choose the local that your copy of WoW is from.



My copy of wow IS EU.. yours may be US etc...

NOW.. click the settings icon in top right (its a cog shape) and choose go Offline.  This will open the launcher window and should update your version of WoW to latest Patch.

Once finished Close the window.  Reload launcher again and select "China" from the list and click "Go Offline" again.  I found that i had to do this to change some settings back again..   Close the launcher again.

Now you should be able to run Wow as usual with WoW.exe.

Hope it helps
Warmaster_Blackhorn 
Bloodscalp TrollBloodscalp Troll

Posts : 355
Joined : 2010-09-08
Male Location : Shanghai

Character in WOW
Server: Alterac澳得兰克 / Arygos亚雷戈斯
Name: Blackhorn, Scribbler, Whitehorn
Guild: Crazy Waiguorens

  Thu 22 May 2014 - 14:55  #
An alternative that always works for me is as follows.

Close all blizzard programs, then delete the agent.db in the battle.net data folder (location below).

Windows XP: \Documents and Settings\All Users\Application Data\Battle.net\agent\agent.db
Windows Vista/7/8: \ProgramData\Battle.net\agent\agent.db
Mac: /Users/Shared/Blizzard/Battle.net (/agent/agent.db?)

After that, restart battle.net client in US or EU region and you should be good to update wow.

Blackhorn


Last edited by Warmaster_Blackhorn on Fri 27 Jun 2014 - 10:00; edited 4 times in total (Reason for editing : Deleted agent.db)
Enea 
DragonmawDragonmaw

Posts : 123
Joined : 2011-05-17

Character in WOW
Server: 奥特兰克
Name: Enea
Guild: The Crazy Waiguoruns

  Thu 22 May 2014 - 15:37  #
Mac: /Users/Shared/Blizzard/Battle.net
Jason Leung 
HarpyHarpy

Posts : 105
Joined : 2010-01-25
Male Age : 22
Location : Wuhan

Character in WOW
Server:
Name:
Guild:

  Thu 22 May 2014 - 16:59  #
Tried enea's method and doesn't work, my stupid client still won't update and says 5.4.7 is "up to date". Out of desperation i try deleting the wow.exe and opening launcher hoping it will fix and update the client somehow. It works lol xD
Gruumsh44 
WyrmWyrm

Posts : 566
Joined : 2007-06-27
Male Age : 33

Character in WOW
Server: region 4 澳得兰克
Name: Gruumsh
Guild: Crazy WaiGuoRens

  Mon 2 Jun 2014 - 6:48  #
Ok i am late to the party... i am confused. I didnt even know there was a new launcher. Can i get directions to how to figure that out 1st?
Warmaster_Blackhorn 
Bloodscalp TrollBloodscalp Troll

Posts : 355
Joined : 2010-09-08
Male Location : Shanghai

Character in WOW
Server: Alterac澳得兰克 / Arygos亚雷戈斯
Name: Blackhorn, Scribbler, Whitehorn
Guild: Crazy Waiguorens

  Tue 3 Jun 2014 - 4:12  #
For the battle.net launcher, the instructions on the US/EU sites are pretty good if I recall correctly. The US launcher works for China region or any other region too. You just select your region whenever you want to log in (or set it for automatic if you want).



Warmaster_Blackhorn 
Bloodscalp TrollBloodscalp Troll

Posts : 355
Joined : 2010-09-08
Male Location : Shanghai

Character in WOW
Server: Alterac澳得兰克 / Arygos亚雷戈斯
Name: Blackhorn, Scribbler, Whitehorn
Guild: Crazy Waiguorens

  Wed 4 Jun 2014 - 0:28  #
Looks like you only have to delete the agent.db file in the battle.net folders to make it recognise your game as a US version. You could probably also edit the file in notepad, but there seems to be rather too many areas where it mentions "cn" or "China".

Updated my previous post accordingly.

Blackhorn
Gruumsh44 
WyrmWyrm

Posts : 566
Joined : 2007-06-27
Male Age : 33

Character in WOW
Server: region 4 澳得兰克
Name: Gruumsh
Guild: Crazy WaiGuoRens

  Fri 6 Jun 2014 - 5:13  #
so, i think i am missing something big, cause i dont have a battle.net folder. My launcher is the older version, not that new shiny one.

so i got it to work
old launcher still visable, but logged in... sneaky hidden folders on C drive.
Mr_spoon 
ImpImp

Posts : 17
Joined : 2010-09-23
Male Location : Beijing

  Wed 18 Jun 2014 - 2:17  #
So I just installed Blizzard's version of Steam the Battlenet launcher.
My game was up to date and working fine in Europe a week ago, and I could even log into the Chinese server if I wanted.
I just came back to Beijing 3 days ago and tried launching the game on the Chinese server, but it said there was a patch, then closed and opened the launcher. Now I can't even open the game if the portal is set to EU, and if it's set to CN, it opens up, says the thing about the patch, then sends me to the launcher.
Now the Battlenet interface says my game is only usable in China.

I think I done goof'd at some point... I usually find a way to fix things, but this time I don't know what to do. Help : /
sleepwholelife 
DefiasDefias

Posts : 54
Joined : 2011-01-19
Male Location : Beijing

Character in WOW
Server: 奥特兰克 (Alterac)
Name: Wakka
Guild: The Crazy Waiguorens

  Wed 18 Jun 2014 - 10:17  #
Blackhorn wrote:
An alternative that always works for me is as follows.

Close all blizzard programs, then delete the agent.db in the battle.net data folder (location below).

Windows XP: \Documents and Settings\All Users\Application Data\Battle.net\agent\agent.db
Windows Vista/7/8: \ProgramData\Battle.net\agent\agent.db
Mac: /Users/Shared/Blizzard/Battle.net (/agent/agent.db?)

After that, restart battle.net client in US or EU region and you should be good to update wow.

Delete whole Battle.net folder, not just agent.db file, then update as usual. Worked for me (i am using old wow launcher).
Mr_spoon 
ImpImp

Posts : 17
Joined : 2010-09-23
Male Location : Beijing

  Thu 19 Jun 2014 - 6:06  #
Good news! I managed to fix the update issue (by reinstalling the game), and everything is working fine!

On the other hand, I got my European account banned in the process, somehow........
Warmaster_Blackhorn 
Bloodscalp TrollBloodscalp Troll

Posts : 355
Joined : 2010-09-08
Male Location : Shanghai

Character in WOW
Server: Alterac澳得兰克 / Arygos亚雷戈斯
Name: Blackhorn, Scribbler, Whitehorn
Guild: Crazy Waiguorens

  Sun 22 Jun 2014 - 7:56  #
Yeah, it seems the option to only delete agent.db is not working. Deleting the whole folder still works, though.
dilannn 
ImpImp

Posts : 14
Joined : 2009-05-12

  Thu 26 Jun 2014 - 22:27  #
Warmaster_Blackhorn wrote:
Yeah, it seems the option to only delete agent.db is not working. Deleting the whole folder still works, though.
Hello I updated my game to full european client, now i change the server from the battle net launcher but it looks like there is no game inside?
now what are the next steps so I can play my EU game in chinese servers?

Warmaster_Blackhorn 
Bloodscalp TrollBloodscalp Troll

Posts : 355
Joined : 2010-09-08
Male Location : Shanghai

Character in WOW
Server: Alterac澳得兰克 / Arygos亚雷戈斯
Name: Blackhorn, Scribbler, Whitehorn
Guild: Crazy Waiguorens

  Fri 27 Jun 2014 - 10:01  #
dilannn wrote:
Warmaster_Blackhorn wrote:
Yeah, it seems the option to only delete agent.db is not working. Deleting the whole folder still works, though.
Hello I updated my game to full european client, now i change the server from the battle net launcher but it looks like there is no game inside?
now what are the next steps so I can play my EU game in chinese servers?


You have to choose the "locate game" option to find it first.
Kirakira 
CorpseCorpse

Posts : 3
Joined : 2013-12-02

  Tue 19 Aug 2014 - 6:14  #
Hello!
I've just returned after a longer break and was surprised to see the new launcher.
I just wonder, does it still work like before? That you have to hold 2 copies of wow, 1 in US/EU and 1 in Chinese? If so, I'm wondering how I should go about to download the US one. Since every time I try to start up the install file, they send me to the Chinese one without any other option.

Or does this work differently now?
GreenMoon 
RaptorRaptor

Posts : 84
Joined : 2006-12-11
Male Age : 53
Location : Shanghai

Character in WOW
Server: MaDuoLan
Name: GreenMoon
Guild:

  Thu 16 Oct 2014 - 17:23  #
Hello mates,

I have on my computer 3 versions of WoW:
1 is the original Chinese version ( 5.4.8 )
2 is the original French original ( 5.4.8 )
3 A French version ( 5.4.8 ) modified with Chinese wow.exe, launcher.exe etc., this is the version I was using to play wow in china with French content

I tried many different ways you mentioned above to update to the new patch without success.

What I'm I doing wrong? can one of you be kind enough to make a detailed process on how to update to this new patch please.

Thanks
rhodekylle 
RaptorRaptor

Posts : 68
Joined : 2007-09-06
Male Age : 56
Location : Beijing

  Fri 17 Oct 2014 - 17:58  #
@GreenMoon

I hope you've already gotten an answer, but I have a similar setup and I'll try to remember what worked for me.

I leave my English copy of the game alone since I only play in China. I'm running Windows 7.

I deleted the whole battle.net folder as mentioned above.

I updated my Chinese client first so that I could see the patch version that we're using.

As far as I recall, I got it to update using the offline option, with the region set to China.

Before starting the update, I manually set the options for game play and the installation folder to my Chinese client's location.

The offline process worked, but it was slow to start and it seemed to lag out a couple of times. When it seemed stuck, I paused and restarted. Restarts are slow but they will pick pick back up.

I waited for the full download to complete before logging in on the Chinese version.

Once the download finished, I logged on to the Chinese version and logged back out.

NEXT:

I play with a hybrid version that I have been patching using the update process in the sticky (changing the two files). Before attempting to update from the US, I changed the launcher.db and WTF files back to the enUS values as we've been doing.

I changed the region to Americas & Southeast Asia.

I repeated the steps for the Chinese update (offline, tell it where my hybrid files are, etc.)

I reverted the changes to the launcher.db and WTF files, just like we've been doing (setting them back the to Chinese values).

I changed my region back to China, but left the folders set to my hybrid.

I logged in on the hybrid version. If I recall correctly, I made the first log in through the new launcher. I've been able to get subsequent launches to work from the hybrid's wow.exe.

I suspect that hot patches may give us some problems over the next few days. I plan to keep checking both versions to make sure we're on the same patch.

Apologies if that's a bit vague, I was short on sleep during the experiment. BE CAREFUL -- do not trigger the annoying Blizzard account security process by logging on to the wrong region. Grrrr. Yeah, I get to deal with customer service now after having made that mistake.

If this helps anyone, good luck and good gaming. If someone would please fact check me, I'd appreciate it. As I said, I've tried to be accurate but I was a tad short on sleep.
GreenMoon 
RaptorRaptor

Posts : 84
Joined : 2006-12-11
Male Age : 53
Location : Shanghai

Character in WOW
Server: MaDuoLan
Name: GreenMoon
Guild:

  Sat 18 Oct 2014 - 10:38  #
Thanks a lot Rhodekylle chinese

I tried to follow your instructions, I don't know what I did but its works Smile
Sponsored content 


  Today at 21:22  #
 

Update client with new Battle.net Launcher to play in China

View previous topic  View next topic  Back to top 
Page 1 of 1

Permissions in this forum: You cannot reply to topics in this forum
Foreign community at Chinese World of Warcraft  :: Technical support -
Private forum on Forumotion | © phpBB | Free forum support | Report an abuse | Free forum