Getting Started
Official links and tools
PortalPortal  HomeHome  GlossaryGlossary  CalendarCalendar  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
WARLORDS OF DREANOR - RELEASE ON 13.11.2014

FOR THOSE HAVING CONNECTIVITY PROBLEMS CHECK HERE!

Share | 
 

 Guide to writing Chinese in WoW with Windows XP/Vista.

View previous topic View next topic Go down 
AlpzStrike 
RaptorRaptor

Posts : 84
Joined : 2007-07-02
Male Location : Shanghai

Character in WOW
Server: CN1 诺莫瑞根
Name: Wezli
Guild: Thai Style

  Thu 14 Aug 2008 - 14:10  #
When I started playing WoW on Windows Vista, i realized i couldn't type chinese and the characters i typed would show up as ???.
This is a fix for that problem which should enable you to type Chinese in-game normally without changing Regional and Language Options.

I will assume you have the chinese fonts for WoW in the Fonts folder and can type Chinese outside the game.
----------------------------------------------------------------------
Download AppLocale.msi from the following location:
http://go.microsoft.com/fwlink/?LinkId=17598



To install the program properly, you must follow these steps:

1) Move your downloaded 'apploc.msi' to C:/System32




2) Press [Start] and type 'cmd'




3) Right click the program and select [Run As Administrator]. This will launch an elevated command prompt with administrator privileges.




4) Type the following into command prompt (without quotes) "apploc.msi"




5) Press the {Enter} key. This will launch the install program for applocale. If you install AppLocale without the above steps, Vista will give you an error unless UAC has been turned off.
Proceed to the next step to run WoW.


6) Run AppLocale and press [Next >]. In the window that displays, select the [Launch an application] radio button.




7) Click [Browse:] and locate WoW.exe on your computer.
Press [Next >] to continue.





8 ) Under [Language of the application] click and scroll down to select 中文(简体). Press [Next >] to continue.




9) In order to always run WoW this way, we should create a shortcut. Select the checkbox to [Create a shortcut to always run this application with AppLocale] and give the link description 'WoW (chinese enabled)'





10) When you click [Finish], WoW will launch. Login and you should find that you can now type chinese (provided you have a Chinese input)


Note: To run WoW the next time, press [Start] > [Programs] > [Microsoft AppLocale]. In that folder you should find a shortcut 'WoW (chinese enabled)'. Click that shortcut and WoW will run using AppLocale. Place a shortcut on your desktop to it for easier access.



----------------------------------------------------------------------
I hope this guide helped and we should all be happily playing WoW with Chinese functionality now. Very Happy
Globuline 
Timmy The CruelTimmy The Cruel

Posts : 788
Joined : 2006-08-07
Female Age : 31
Location : Paris

Character in WOW
Server: maduolan-马多兰
Name: Globuline
Guild: Cow Eaters

  Sun 17 Aug 2008 - 13:11  #
Thanks for that nice guide. I've changed it as a sticky.

_________________
I remember faces easily, but I'll make an exception for you.
-----------
A frog's life
A frog's life sur facebook
Ze blog BD sans dessin
skar 
MurlocMurloc

Posts : 37
Joined : 2010-12-04

  Mon 6 Dec 2010 - 14:22  #
I want to add that the option to create a shortcut only appears if you do not select the same language as you may have selected in systemlocale in the control panel.

So in case you thought you are smart and already changed systemlocale to chinese you need to revert that setting Smile.

ryuuken 
ImpImp

Posts : 11
Joined : 2011-06-24

  Fri 24 Jun 2011 - 23:08  #
I can't get this to work on EU servers, is it not supposed to?
Cheese 
RaptorRaptor

Posts : 65
Joined : 2011-08-19
Male Location : Shenzhen

Character in WOW
Server: 鬼雾峰-CN3
Name: Brie
Guild:

  Sat 30 Jun 2012 - 17:08  #
Any tips if this doesnt work?
I can use chinese typing for any program on this computer Except WOW and its really annoying me.

Chinese input doesnt work, and it wont create a shortcut. Uninstalled and re-installed, will try once again.
StiXx 
NecromancerNecromancer

Posts : 702
Joined : 2008-06-11
Male Age : 30
Location : Guangzhou / Eindhoven

Character in WOW
Server: 奥特兰克-CN1(PVP)
Name: Avanti
Guild: The Crazy Waiguorens

  Tue 3 Jul 2012 - 5:43  #
This one works for me.
Use it on wow.exe and only launch from the applocale software.

Im using windows7.

Cheese 
RaptorRaptor

Posts : 65
Joined : 2011-08-19
Male Location : Shenzhen

Character in WOW
Server: 鬼雾峰-CN3
Name: Brie
Guild:

  Wed 4 Jul 2012 - 11:05  #
Yeah that's the strangest part. I pick everythign according to the directions, and.. thats it, no text input change.
Changed the hotkeys for switching between roman input and pinyin, still no change.

Tweaking things to make sure its not me, but guess I have to just keep trying.
Sponsored content 


  Today at 20:11  #
 

Guide to writing Chinese in WoW with Windows XP/Vista.

View previous topic  View next topic  Back to top 
Page 1 of 1

Permissions in this forum: You cannot reply to topics in this forum
Foreign community at Chinese World of Warcraft  :: Technical support -
Free forum | © phpBB | Free forum support | Report an abuse | Free forum