Getting Started
Official links and tools
PortalPortal  HomeHome  GlossaryGlossary  CalendarCalendar  FAQFAQ  SearchSearch  RegisterRegister  Log inLog in  
WARLORDS OF DREANOR - RELEASE ON 13.11.2014

FOR THOSE HAVING CONNECTIVITY PROBLEMS CHECK HERE!

Share | 
 

 New Patch trouble - U.S. Client

View previous topic View next topic Go down 
mcnutface 
RaptorRaptor

Posts : 85
Joined : 2008-03-30
Age : 46

Character in WOW
Server: Beijing 2 - 库尔提拉斯
Name: Mcnutface
Guild:

  Sun 30 Mar 2008 - 7:04  #
I am using my U.S. / English client I bought back home, I have been using it for months and no problem. With the new patch 2.4.0.0889 I cant seem to log on though. I am getting the "Unable to validate game version" message. I usually get this when the Chinese patch hasnt come out yet, or I need to repair. I did repair(from u.s. servers) and still the same message. Any suggustions? Is anyone else having problems? Is anyones English client working fine with the new update?

Thanks in advance


nevermind guess you can dl the patch on the chinawow website before the servers update.
 

New Patch trouble - U.S. Client

View previous topic  View next topic  Back to top 
Page 1 of 1

Permissions in this forum: You cannot reply to topics in this forum
Foreign community at Chinese World of Warcraft  :: Technical support -
Private forum on Forumotion | © phpBB | Free forum support | Report an abuse | Free forum